<!doctype html><html lang=en-US class=gnt__njs data-u-s=anon><head><meta charset=utf-8 /><meta name=viewport content="width=device-width,initial-scale=1,minimum-scale=1"/><meta name=theme-color content=#0098FE /><title>What to Expect at El Segundo, CMR's Forthcoming Mexican Restaurant</title><meta property=og:title content="What to Expect at El Segundo, Cameron Mitchell’s Forthcoming Mexican Restaurant"/><link rel=amphtml href=https://amp.columbusmonthly.com/amp/8184097002 /><meta property=article:author content="Erin Edwards"/><meta property=article:content_tier content=metered /><meta property=article:opinion content=false /><link rel=dns-prefetch href=//user.columbusmonthly.com /><link rel=preconnect href=https://user.columbusmonthly.com /><link rel=dns-prefetch href=//www.gannett-cdn.com /><link rel=dns-prefetch href=//securepubads.g.doubleclick.net /><link rel=preconnect href=https://securepubads.g.doubleclick.net /><link rel=dns-prefetch href=//adservice.google.com /><link rel=preconnect href=https://adservice.google.com /><link rel=dns-prefetch href=//tpc.googlesyndication.com /><link rel=preconnect href=https://tpc.googlesyndication.com /><link rel=dns-prefetch href=//googleads.g.doubleclick.net /><link rel=dns-prefetch href=//s0.2mdn.net /><link rel=dns-prefetch href=//partner.googleadservices.com /><link rel=dns-prefetch href=//www.googletagservices.com /><link rel=preconnect href=https://www.googletagservices.com /><link rel=dns-prefetch href=//static.adsafeprotected.com /><link rel=preconnect href=https://static.adsafeprotected.com /><link rel=dns-prefetch href=//pixel.adsafeprotected.com /><link rel=preconnect href=https://pixel.adsafeprotected.com crossorigin/><link rel=dns-prefetch href=//c.amazon-adsystem.com /><link rel=preconnect href=//c.amazon-adsystem.com /><link rel=dns-prefetch href=//js-sec.indexww.com /><link rel=preconnect href=https://js-sec.indexww.com /><link rel=dns-prefetch href=//aax.amazon-adsystem.com /><link rel=preconnect href=//aax.amazon-adsystem.com /><link rel=dns-prefetch href=//fastlane.rubiconproject.com /><link rel=preconnect href=https://fastlane.rubiconproject.com /><link rel=dns-prefetch href=//bidder.criteo.com /><link rel=preconnect href=https://bidder.criteo.com /><link rel=dns-prefetch href=//colossusssp.com /><link rel=preconnect href=https://colossusssp.com /><link rel=dns-prefetch href=//gannett-d.openx.net /><link rel=preconnect href=https://gannett-d.openx.net /><link rel=dns-prefetch href=//hbopenbid.pubmatic.com /><link rel=preconnect href=https://hbopenbid.pubmatic.com /><link rel=dns-prefetch href=//ads.pubmatic.com /><link rel=dns-prefetch href=//as-sec.casalemedia.com /><link rel=preconnect href=https://as-sec.casalemedia.com /><link rel=dns-prefetch href=//ib.adnxs.com /><link rel=preconnect href=https://ib.adnxs.com /><link rel=dns-prefetch href=//adserver.adtechus.com /><link rel=preconnect href=https://adserver.adtechus.com /><link rel=dns-prefetch href=//apex.go.sonobi.com /><link rel=preconnect href=https://apex.go.sonobi.com /><link rel=dns-prefetch href=//sofia.trustx.org /><link rel=preconnect href=https://sofia.trustx.org /><link rel=dns-prefetch href=//tlx.3lift.com /><link rel=preconnect href=https://tlx.3lift.com /><link rel=dns-prefetch href=//e.serverbid.com /><link rel=preconnect href=https://e.serverbid.com /><link rel=dns-prefetch href=//confiant-integrations.global.ssl.fastly.net /><link rel=preconnect href=https://confiant-integrations.global.ssl.fastly.net /><link rel=dns-prefetch href=//a.teads.com /><link rel=dns-prefetch href=//a.teads.tv /><link rel=preconnect href=https://a.teads.tv /><link rel=dns-prefetch href=//geolocation.onetrust.com /><link rel=preconnect href=https://geolocation.onetrust.com /><link rel=dns-prefetch href=//atoms.columbusmonthly.com /><link rel=dns-prefetch href=//cdn.taboola.com /><link rel=preconnect href=https://cdn.taboola.com /><link rel=dns-prefetch href=//trc.taboola.com /><link rel=preconnect href=https://trc.taboola.com /><link rel=dns-prefetch href=//www.usatodaynetworkservice.com /><link rel=preload as=fetch type=application/json href=https://user.columbusmonthly.com/NCOM-GUP/user/ crossorigin=use-credentials /><link rel=preload as=script href=/tangstatic/js/pbjsandwich-q1a2z36b1cc949.min.js /><link rel=preload as=script href=https://c.amazon-adsystem.com/aax2/apstag.js /><link rel=preload as=script href=https://js-sec.indexww.com/ht/p/184808-89514051626416.js /><link rel=preload as=script href=https://static.adsafeprotected.com/iasPET.1.js /><link rel=preload as=script href=https://securepubads.g.doubleclick.net/tag/js/gpt.js /><link rel=preload as=script href=https://confiant-integrations.global.ssl.fastly.net/r5TdgVvkbv-PeaJCKaQfCh5Xsto/gpt_and_prebid_v3l/config.js /><link rel=preload as=script href=/tangstatic/js/main-q1a2z3f82099ad.min.js /><link rel=preload as=script href=https://geolocation.onetrust.com/cookieconsentpub/v1/geo/location/gnt.otgc /><link rel=preload as=script href=https://cdn.taboola.com/libtrc/gannett-network/loader.js /><meta name=description content="Cameron Mitchell Restaurants’ first Mexican concept is set to open Aug. 31 in the former Harvey & Ed’s space in the Short North."/><meta property=og:description content="Cameron Mitchell Restaurants’ first Mexican concept is set to open Aug. 31 in the former Harvey & Ed’s space in the Short North."/><meta property=fb:pages content=10157975852223613 /><meta property=fb:app_id content=212857700411789 /><link rel=canonical href=https://www.columbusmonthly.com/story/lifestyle/food/2021/08/18/what-expect-el-segundo-cmrs-forthcoming-mexican-restaurant/8184097002/ /><meta property=og:url content=https://www.columbusmonthly.com/story/lifestyle/food/2021/08/18/what-expect-el-segundo-cmrs-forthcoming-mexican-restaurant/8184097002/ /><meta property=og:site_name content="Columbus Monthly"/><meta property=og:image content="https://www.gannett-cdn.com/presto/2021/08/18/NCOM/17eff154-f329-487c-9fcc-251b94b8dd38-CCP_6849_1.jpg?crop=5759,3240,x0,y192&width=3200&height=1801&format=pjpg&auto=webp"/><meta property=og:image:width content=3200 /><meta property=og:image:height content=1801 /><meta name=ROBOTS content="NOODP, NOYDIR, max-image-preview:large"/><meta name=google content=notranslate /><meta property=og:type content=article /><script>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</script><style>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</style><meta name=twitter:card content=summary_large_image /><meta name=twitter:image content="https://www.gannett-cdn.com/presto/2021/08/18/NCOM/17eff154-f329-487c-9fcc-251b94b8dd38-CCP_6849_1.jpg?crop=5759,3240,x0,y192&width=1600&height=800&format=pjpg&auto=webp"/><meta name=twitter:site content=@columbusmonthly /><meta name=twitter:creator content=@columbusmonthly /><meta name=twitter:title content="What to Expect at El Segundo, Cameron Mitchell’s Forthcoming Mexican Restaurant"/><meta name=twitter:description content="Cameron Mitchell Restaurants’ first Mexican concept is set to open Aug. 31 in the former Harvey & Ed’s space in the Short North."/></head><body><svg style=display:none><symbol id=gnt_svg_external viewBox="0 0 18 18"><path d="M12.43 5.5H10.5V4H15v4.5h-1.5V6.55l-4.56 4.56-1.06-1.06 4.55-4.55zm1.07 9v-3.75H15V16H3V4h5.25v1.5H4.5v9h9z"/></symbol><svg id=gnt_svg_share_facebook viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#4460a0)><path d="M10.5932 20.9998C6.291 20.3204 3 16.5743 3 12.055 3 7.054 7.0294 3 12 3s9 4.054 9 9.0549c0 4.5198-3.2914 8.266-7.5943 8.9451v-6.3188h2.097l.3991-2.6175h-2.496v-1.6985c0-.716.3486-1.414 1.4666-1.414h1.1349V6.7227s-1.03-.1769-2.0146-.1769c-2.0558 0-3.3995 1.2536-3.3995 3.523v1.9948H8.3081v2.6175h2.2851v6.3186z"/></svg><symbol id=gnt_svg_share_twitter viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#00aaec)><path d="M21 6.776a7.213 7.213 0 0 1-2.12.596 3.778 3.778 0 0 0 1.623-2.095 7.273 7.273 0 0 1-2.346.918A3.642 3.642 0 0 0 15.462 5c-2.038 0-3.692 1.696-3.692 3.787 0 .296.032.585.095.862-3.069-.158-5.79-1.664-7.612-3.958a3.856 3.856 0 0 0-.5 1.906c0 1.313.652 2.472 1.643 3.152a3.626 3.626 0 0 1-1.673-.473v.047c0 1.835 1.273 3.366 2.963 3.713-.31.089-.636.133-.973.133-.238 0-.47-.023-.695-.067.47 1.504 1.833 2.599 3.45 2.628A7.292 7.292 0 0 1 3 18.3 10.282 10.282 0 0 0 8.66 20c6.794 0 10.508-5.77 10.508-10.774 0-.164-.003-.329-.01-.49A7.58 7.58 0 0 0 21 6.776"/></symbol><symbol id=gnt_svg_share_email viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#626262)><path d="M3 5.88c0-.49.4-.88.9-.88h16.2c.5 0 .9.4.9.88v12.24c0 .49-.4.88-.9.88H3.9a.9.9 0 0 1-.9-.88V5.88zm9 5.21L3 6.74v1.74l9 4.35 9-4.35V6.74l-9 4.35z"/></symbol><symbol id=gnt_svg_shareapi viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#000)><path d="M14 5l6 7-6 7V5zm0 4v6c-1.937-.271-3.937.062-6 1s-3.73 2.271-5 4c.909-3.576 2.242-6.242 4-8s4.091-2.758 7-3z"/></symbol></svg><header class=gnt_n onmousedown=event.stopPropagation() onmouseup=event.stopPropagation()><div class=gnt_n_lg_w><button class=gnt_n_sb data-g-r=base_sb data-t-l=":n|v|c|skip to main content" aria-label="Skip to main content"></button><a class=gnt_n_lg href=/ aria-label="Columbus Monthly" data-t-l=:n|v|c|logo><svg class=gnt_n_lg_svg id=gnt_svg_lg fill=#303030 preserveAspectRatio="xMinYMid meet" viewBox="0 0 285.63 28.41"><path d="M15.51 23.66c-.66 1.93-2 4.66-6.94 4.66C1.6 28.33 0 23.66 0 18.24v-.29c0-3.06 1.06-7 4.15-8.63a9.92 9.92 0 014.62-1.13c4.66 0 7.21 2.08 7.21 4.8 0 1.17-.73 2.55-2.8 2.55a2.54 2.54 0 01-2.7-2.36v-.11c-.01-.3.05-.6.18-.88.31-.5.72-.94 1.2-1.28.18-.14.37-.32.37-.5 0-1.39-1.86-1.71-3.21-1.71-3.13 0-3.64 3.49-3.64 4.88v9.21c0 2.66 1.6 4.91 3.81 4.91 2.81 0 4.59-1.13 5.76-4.18l.55.14m.65-5.46c0-5.2 2.86-10 9.25-10 6.52 0 9.28 5.03 9.28 10 0 5.21-3.06 10.12-9.28 10.12-6.49.01-9.25-4.91-9.25-10.12m13.18-2.14c0-4.19-.51-7.25-3.93-7.25s-3.89 3.06-3.89 7.25v5.5c0 2.69.54 6.19 3.89 6.19s3.93-3.49 3.93-6.19v-5.5zM43.8 26.69a2.7 2.7 0 01-2.73 1.71h-.44c-3.13 0-4.59-1.28-4.59-4.34V.55h-1.57V0h6.37v26.73a1 1 0 00.97 1.02h.05a1.48 1.48 0 001.31-1.06h.63m17.14-.03c-.02.55.41 1 .96 1.02h.06a1.47 1.47 0 001.31-1.05h.62a2.7 2.7 0 01-2.73 1.71h-.44c-3.13 0-4.4-1.46-4.59-3.17-.25.58-1.46 3.17-4.51 3.17-5.67-.01-7.34-3.79-7.34-7.69V9.28H42.7v-.54h6.37v14.05c0 1.9.14 4.95 2.55 4.95 3.46 0 4.51-3.38 4.51-5.43V9.25h-1.56v-.51h6.36v17.92m35.18.03a2.7 2.7 0 01-2.73 1.71h-.44c-3.13 0-4.62-1.28-4.62-4.34v-9.83c0-2.15-.04-5.38-2.11-5.38-2.95 0-4.26 3.17-4.26 5.68v12.92h1.6v.51h-7.94v-.51h1.57V14.02c0-2.29-.08-5.24-2.26-5.24-2.86 0-4.41 2.86-4.41 5.43v13.25h1.53v.51h-7.9v-.51h1.55V9.28h-1.57v-.54h6.37v2.55c.15-.8 1.86-3.09 4.44-3.09 3.42 0 5.64 1.31 6.59 4.4.26-1.78 1.6-4.28 4.92-4.28 4.84 0 6.7 2.51 6.7 7.43v11a1 1 0 00.97 1.02h.05a1.48 1.48 0 001.31-1.06h.62m3.94-15.68c.58-1.24 2-2.86 4.91-2.86a8.03 8.03 0 016.96 3.6c.84 1.37 1.4 3.46 1.4 6.39 0 4.7-1.97 10.16-8.59 10.16-7 0-9.5-4.69-9.5-9.64V.55h-1.57V0h6.37v11.03m7.98 6.48c0-4.88 0-8.7-3.09-8.7a4.66 4.66 0 00-4.86 4.45v7.99c0 3.17.95 6.45 4.19 6.45s3.78-3.02 3.78-5.75l-.02-4.44zm23.53 9.15c-.02.55.41 1 .96 1.02h.06a1.47 1.47 0 001.31-1.05h.62a2.7 2.7 0 01-2.73 1.71h-.44c-3.13 0-4.4-1.46-4.58-3.17-.26.58-1.46 3.17-4.52 3.17-5.68 0-7.36-3.81-7.36-7.68V9.28h-1.55v-.54h6.37v14.05c0 1.9.14 4.95 2.55 4.95 3.46 0 4.52-3.38 4.52-5.43V9.25h-1.57v-.51h6.37v17.92m3.47 1.3v-3.81l.62.04c1.2 2.38 2.99 3.49 5.87 3.49 3.33 0 5.46-.95 5.46-3.2 0-1.97-1.35-2.69-5.32-3.78-4.28-1.17-6.56-2.08-6.56-6.7 0-3.13 1.97-5.78 7.06-5.78a7.19 7.19 0 014.33 1.31c.22.14.37.26.48.26.11 0 .21-.26.21-.8v-.27h.55l-.07 3.46-.73-.04c-.4-2.38-2.86-3.31-5.2-3.31-2.62 0-4.81 1.35-4.81 3.49s2.77 2.44 7.36 3.64c3.46.87 4.69 3.2 4.69 5.9 0 4.22-2.04 6.44-7.46 6.44-1.97 0-3.57-.32-5.03-1.71-.32-.33-.51-.55-.65-.55s-.22.51-.26 1.9l-.54.02m41.6.16l-.29-13.77-6.91 11.78h-.3l-6.96-11.8-.24 13.79h-2.15l.74-19.8.4-.05 8.46 14.67 8.24-14.67.42.05.75 19.8zm15.1.32c-5.27 0-9.62-4.2-9.62-10.05a9.86 9.86 0 019.65-10.07h.16c5.27 0 9.62 4.22 9.62 10.07a9.84 9.84 0 01-9.63 10.05h-.18m.11-18.21c-4.34 0-7.42 3.57-7.42 8.16s3.08 8.16 7.42 8.16 7.39-3.56 7.39-8.16-3.06-8.16-7.39-8.16m28.08 18.27l-12.65-15.16v14.79h-2.13V8.37l.42-.1 12.49 14.91V8.64h2.14v19.78zm11.69-17.95v17.57h-2.12V10.55h-6.51V8.64h15.12v1.91zm21.83 17.57v-8.93h-10.42v8.93h-2.12V8.64h2.12v8.64h10.42V8.64h2.13v19.48zm6.38 0V8.64h2.13v17.57h9.28v1.91zm18.99-8.63v8.64h-2.13v-8.67l-6.84-10.82h2.4l5.59 9.04 5.49-9.04h2.34z"/></svg></a></div><div class="gnt_n_sm gnt_n_nc__hbn"><a class=gnt_n_sm_a data-u-sr="anon reg" href="https://subscribe.columbusmonthly.com/specialoffer?gps-source=CPMASTHEAD&itm_campaign=2021SUMMERFUN&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.columbusmonthly.com%2Fstory%2Flifestyle%2Ffood%2F2021%2F08%2F18%2Fwhat-expect-el-segundo-cmrs-forthcoming-mexican-restaurant%2F8184097002%2F" target=_blank rel=noopener data-t-l=":tiffany tile (right masthead)|p|c|${m} " elementtiming=nav-submsg></a></div><nav class=gnt_n_mn aria-label="Global navigation"><a class="gnt_n_mn_l gnt_n_mn_l__fi gnt_n_mn_ce" href=https://stories.usatodaynetwork.com/monthlyguidetocolumbus/home/site/columbusmonthly.com data-t-l=:n|v|c|guides elementtiming=nav-item>Guides</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/arch-city/ data-t-l=:n|v|c|arch-city>Arch City</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/home-style/ data-t-l=:n|v|c|home-style>Home & Style</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/dining/ data-t-l=:n|v|c|dining>Dining</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/features/ data-t-l=:n|v|c|features>Features</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/weddings/ data-t-l=:n|v|c|weddings>Weddings</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://www.publicnoticesohio.com/ data-t-l=:n|v|c|legals>Legals</a><div class=gnt_n_dd_w data-g-r="nav_ce nav_sh"><button class="gnt_n_dd_bt gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navgdp data-g-ltn=navgd data-t-l=:m|v|g|caret aria-label="Global Navigation" aria-haspopup=true aria-expanded=false><svg class=gnt_n_dd_bt_svg viewBox="0 0 10 6"><path d="M5 3.35L8.64 0 10 1.4 5 6 0 1.4 1.36 0z"/></svg></button></div><div class=gnt_n_us><div class=gnt_n_se data-g-r=nav_ce><a class="gnt_n_se_a gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navse href=/search/ data-t-l=:r|r|g|icon title=Search aria-label=Search aria-haspopup=true aria-expanded=false><svg class=gnt_n_se_a_svg viewBox="0 0 24 24"><path d="M15.75 14.33l4.96 4.96-1.42 1.42-4.96-4.96a6.5 6.5 0 1 1 1.41-1.41zM10.5 15a4.5 4.5 0 1 0 0-9 4.5 4.5 0 0 0 0 9z"/></svg></a></div><a class="gnt_n_wt gnt_n_mn_ce" href=/weather/ target=_blank rel="external noopener" aria-label="Weather in Columbus" title="Weather in Columbus" data-t-l=:n|v|c|weather></a> <a class=gnt_n_us_sb data-u-sr="anon reg" href="https://subscribe.columbusmonthly.com/specialoffer?gps-source=CPTOPNAVBAR&itm_campaign=2021SUMMERFUN&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.columbusmonthly.com%2Fstory%2Flifestyle%2Ffood%2F2021%2F08%2F18%2Fwhat-expect-el-segundo-cmrs-forthcoming-mexican-restaurant%2F8184097002%2F" target=_blank rel=noopener data-t-l=:n|p|c|subscribe elementtiming=nav-subbt>Subscribe</a></div></nav></header><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__hi"><div id=ad-slot-7103-oh-columbus-monthly-C6771-high_impact-lifestyle-food-1 class="gnt_x_sl gnt_x_hi"></div></aside><div class=gnt_bc></div><div class=gnt_cw_w><a class=gnt_cw_sl data-g-r=base_xbutton href=/ data-t-l=:b|v|c|overlay aria-label=Close aria-hidden=true tabindex=-1></a> <a class="gnt_cw_sl gnt_cw_sl__ed" data-g-r=base_xbutton href=/ data-t-l=:b|v|c|overlay aria-label=Close aria-hidden=true tabindex=-1></a><main class=gnt_cw><div class=gnt_ar_lbl aria-label=Food data-c-ssts=FOOD></div><article class=gnt_pr><h1 class=gnt_ar_hl elementtiming=ar-headline>What to Expect at El Segundo, Cameron Mitchell’s Forthcoming Mexican Restaurant</h1><h2 class=gnt_ar_shl>Cameron Mitchell Restaurants’ first Mexican concept is set to open Aug. 31 in the former Harvey & Ed’s space in the Short North.</h2><div class=gnt_ar_by><a href=/staff/4392941001/erin-edwards/ class="gnt_ar_by_a gnt_ar_by_a__fi">Erin Edwards</a><div class=gnt_ar_pb>Columbus Monthly</div></div><div class=gnt_ar_dt aria-label="Published: 3:14 p.m. ET Aug. 18, 2021 Updated: 3:59 p.m. ET Aug. 18, 2021"></div><div class=gnt_ss data-g-r=base_sc data-ss-u=https://www.columbusmonthly.com/story/lifestyle/food/2021/08/18/what-expect-el-segundo-cmrs-forthcoming-mexican-restaurant/8184097002/ data-ss-t="What to Expect at El Segundo, Cameron Mitchell’s Forthcoming Mexican Restaurant" data-ss-d="Cameron Mitchell Restaurants’ first Mexican concept is set to open Aug. 31 in the former Harvey & Ed’s space in the Short North."><a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=212857700411789&href=https%3A%2F%2Fwww.columbusmonthly.com%2Fstory%2Flifestyle%2Ffood%2F2021%2F08%2F18%2Fwhat-expect-el-segundo-cmrs-forthcoming-mexican-restaurant%2F8184097002%2F" data-g-r=base_si data-ss-a=f data-t-l=:h|v|c|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.columbusmonthly.com%2Fstory%2Flifestyle%2Ffood%2F2021%2F08%2F18%2Fwhat-expect-el-segundo-cmrs-forthcoming-mexican-restaurant%2F8184097002%2F&text=What%20to%20Expect%20at%20El%20Segundo%2C%20Cameron%20Mitchell%E2%80%99s%20Forthcoming%20Mexican%20Restaurant&via=columbusmonthly" data-g-r=base_si data-ss-a=t data-t-l=:h|v|c|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject=What%20to%20Expect%20at%20El%20Segundo%2C%20Cameron%20Mitchell%E2%80%99s%20Forthcoming%20Mexican%20Restaurant%20-%20from%20Columbus%20Monthly&body=What%20to%20Expect%20at%20El%20Segundo%2C%20Cameron%20Mitchell%E2%80%99s%20Forthcoming%20Mexican%20Restaurant%0A%0ACameron%20Mitchell%20Restaurants%E2%80%99%20first%20Mexican%20concept%20is%20set%20to%20open%20Aug.%2031%20in%20the%20former%20Harvey%20%26%20Ed%E2%80%99s%20space%20in%20the%20Short%20North.%0A%0ACheck%20out%20this%20story%20on%20columbusmonthly.com%3A%20https%3A%2F%2Fwww.columbusmonthly.com%2Fstory%2Flifestyle%2Ffood%2F2021%2F08%2F18%2Fwhat-expect-el-segundo-cmrs-forthcoming-mexican-restaurant%2F8184097002%2F" data-t-l=:h|v|c|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=:h|v|c|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><div class=gnt_ar_b><figure class="gnt_em gnt_em__fp gnt_em_img"><img class=gnt_em_img_i style=height:440px src="https://www.gannett-cdn.com/presto/2021/08/18/NCOM/17eff154-f329-487c-9fcc-251b94b8dd38-CCP_6849_1.jpg?width=660&height=440&fit=crop&format=pjpg&auto=webp" elementtiming=ar-lead-image srcset="https://www.gannett-cdn.com/presto/2021/08/18/NCOM/17eff154-f329-487c-9fcc-251b94b8dd38-CCP_6849_1.jpg?width=1320&height=880&fit=crop&format=pjpg&auto=webp 2x" decoding=async alt="A selection of tacos from El Segundo Mexican Kitchen"/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="A selection of tacos from El Segundo Mexican Kitchen" data-c-credit="Courtesy Cameron Mitchell Restaurants"></div></figure><p class=gnt_ar_b_p>In some ways, Cameron Mitchell’s colorful new restaurant opening on Aug. 31 in the Short North is about second chances. </p><p class=gnt_ar_b_p>Dubbed <a href=https://elsegundocolumbus.com/ target=_blank rel=noopener data-t-l=":b|e|inline click|${u}" class=gnt_ar_b_a>El Segundo</a>—meaning “the second”—CMR’s first-ever Mexican restaurant is actually the company’s second swat at success at 698 N. High St. CMR’s first attempt in the 4,100-square-foot space, <a href=https://www.columbusmonthly.com/foodanddining/20190807/restaurant-review-harvey--eds target=_blank rel=noopener data-t-l=":b|e|inline click|${u}" class=gnt_ar_b_a>Harvey & Ed’s</a>, was a short-lived delicatessen concept that attempted to fill the beloved Rigsby’s Kitchen space. The deli, which was named after CMR president and Chief Operating Officer (COO) David Miller’s uncle and father, made multiple attempts to connect with customers through menu changes but never found its footing during the dinner hours, Miller says.</p><p class=gnt_ar_b_p>CMR is never short on ideas, though, as a look up and down High Street can affirm; CMR’s Short North establishments will total seven once El Segundo opens. Having already covered Italian, Pan-Asian, Steakhouse, farm-to-table and California fare, Miller says CMR has been batting around ideas for a Mexican concept for some time. In fact, a Mexican restaurant was originally planned for the Short North’s Del Mar SoCal space until several CMR executives took a trip to California and came back with ideas that birthed Del Mar.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-oh-columbus-monthly-C6771-native-article_link-lifestyle-food-2 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>Mexican food is a thriving, competitive area of cuisine in Columbus. The city is rich with taco trucks, immigrant-owned mom-and-pop restaurants, Mexican groceries and trendy taco chains like Condado, Bakersfield and Barrio. Why, then, did CMR feel like Columbus needed El Segundo? Miller says he believes the restaurant, with its lively décor, tequila-focused bar program and CMR-trained staff, fills an upmarket niche in the city. (I would argue that it’s attempting to take up the mantle of Mexican-themed spots like Cosecha Cocina (formerly in Italian Village) or the bygone Abuelo’s at Easton.)</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-oh-columbus-monthly-C6771-native-article_link-lifestyle-food-3 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>"They're all great in their own right, and they've got their own brand and their own niche and that's the way we're taking the approach. We have our own brand, our own niche. I just go back to the physical [space], and you walk in here and your eyes just kind of go wide open,” Miller says. “Culinarily, our chef team has done a fabulous job creating an incredible menu that is very diverse and well thought out.”</p><aside class="gnt_em gnt_em_anc" id=gnt_atomsnc data-g-r=lazy data-gl-method=loadAnc aria-label="Newsletter signup form"></aside><p class=gnt_ar_b_p>From a food standpoint, El Segundo will offer starters such as esquites (Mexican street corn) and barbacoa tamales as well as tacos, burritos and entrees such as fajitas and carne asada. House-made desserts, often a strength at CMR-owned restaurants, include churro doughnuts, tres leches and flan. On the bar side, customers will find a generous margarita selection, craft cocktails and about a hundred different tequilas, including one handpicked by CMR, a double-barrel añejo tequila from Hacienda Herradura in Jalisco, Mexico.</p><figure class="gnt_em gnt_em_img"><img class=gnt_em_img_i style=height:495px data-g-r=lazy data-gl-src="https://www.gannett-cdn.com/presto/2021/08/18/NCOM/536b7ea5-cb2d-4590-bb73-98fcb3aa7f03-IMG_6930_1.jpg?width=660&height=495&fit=crop&format=pjpg&auto=webp" data-gl-srcset="https://www.gannett-cdn.com/presto/2021/08/18/NCOM/536b7ea5-cb2d-4590-bb73-98fcb3aa7f03-IMG_6930_1.jpg?width=1320&height=990&fit=crop&format=pjpg&auto=webp 2x" decoding=async alt="The bar at El Segundo Mexican Kitchen, which opens August 31"/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="The bar at El Segundo Mexican Kitchen, which opens August 31" data-c-credit="Erin Edwards"></div></figure><p class=gnt_ar_b_p>Past visitors to Harvey & Ed’s will hardly recognize the renovated dining room and bar, which incorporates darker wood features, more art and certainly more pops of color (lime green to be exact). Harvey & Ed’s deli cases have been ripped out, and the kitchen now features new equipment like a spit for tacos al pastor and a press for house-made tortillas. The dining room features Day of the Dead murals by local artists, alebrijes (Mexican folk art sculptures) on the walls, colorful textiles, bright lime green seating and sombreros suspended from the ceiling. Understated it is not.</p><p class=gnt_ar_b_p>"The art component of this brand...I mean, it's a piece of art. You see the murals all over ... it really felt [like] the Short North Arts District," Miller says, adding that he thinks El Segundo will appeal to the neighborhood’s demographic. "Tequila and tequila bars are definitely very well received. The clientele in the Short North is ... skewed a little bit younger. And I think this style of cocktail menu and this style of cuisine is going to serve the clientele here very well."</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-oh-columbus-monthly-C6771-native-article_link-lifestyle-food-4 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>Leading the El Segundo team will be executive chef Geoff Baumberger and general manager Jessica Stull. The restaurant’s grand opening is set for Tuesday, Aug. 31, and it will be open six nights a week to start (closed on Mondays); Miller says CMR plans to add brunch at a later date. “We’ll probably start that in a month or so, but I want to get dinner open first,” he says. “With football season on the horizon here, we certainly want to get brunch open as soon as we can but do it right. That's the only way to do it.”</p><figure class="gnt_em gnt_em__lp gnt_em_img"><img class=gnt_em_img_i style=height:440px data-g-r=lazy data-gl-src="https://www.gannett-cdn.com/presto/2021/08/18/NCOM/21978e04-3118-4f47-9837-44067b9d2a90-CCP_6951.jpg?width=660&height=440&fit=crop&format=pjpg&auto=webp" data-gl-srcset="https://www.gannett-cdn.com/presto/2021/08/18/NCOM/21978e04-3118-4f47-9837-44067b9d2a90-CCP_6951.jpg?width=1320&height=880&fit=crop&format=pjpg&auto=webp 2x" decoding=async alt="Tres leches at El Segundo Mexican Kitchen"/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="Tres leches at El Segundo Mexican Kitchen" data-c-credit="Courtesy Cameron Mitchell Restaurants"></div></figure></div><div class=gnt_ss data-g-r=base_sc data-ss-u=https://www.columbusmonthly.com/story/lifestyle/food/2021/08/18/what-expect-el-segundo-cmrs-forthcoming-mexican-restaurant/8184097002/ data-ss-t="What to Expect at El Segundo, Cameron Mitchell’s Forthcoming Mexican Restaurant" data-ss-d="Cameron Mitchell Restaurants’ first Mexican concept is set to open Aug. 31 in the former Harvey & Ed’s space in the Short North."><a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=212857700411789&href=https%3A%2F%2Fwww.columbusmonthly.com%2Fstory%2Flifestyle%2Ffood%2F2021%2F08%2F18%2Fwhat-expect-el-segundo-cmrs-forthcoming-mexican-restaurant%2F8184097002%2F" data-g-r=base_si data-ss-a=f data-t-l=:i|v|c|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.columbusmonthly.com%2Fstory%2Flifestyle%2Ffood%2F2021%2F08%2F18%2Fwhat-expect-el-segundo-cmrs-forthcoming-mexican-restaurant%2F8184097002%2F&text=What%20to%20Expect%20at%20El%20Segundo%2C%20Cameron%20Mitchell%E2%80%99s%20Forthcoming%20Mexican%20Restaurant&via=columbusmonthly" data-g-r=base_si data-ss-a=t data-t-l=:i|v|c|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject=What%20to%20Expect%20at%20El%20Segundo%2C%20Cameron%20Mitchell%E2%80%99s%20Forthcoming%20Mexican%20Restaurant%20-%20from%20Columbus%20Monthly&body=What%20to%20Expect%20at%20El%20Segundo%2C%20Cameron%20Mitchell%E2%80%99s%20Forthcoming%20Mexican%20Restaurant%0A%0ACameron%20Mitchell%20Restaurants%E2%80%99%20first%20Mexican%20concept%20is%20set%20to%20open%20Aug.%2031%20in%20the%20former%20Harvey%20%26%20Ed%E2%80%99s%20space%20in%20the%20Short%20North.%0A%0ACheck%20out%20this%20story%20on%20columbusmonthly.com%3A%20https%3A%2F%2Fwww.columbusmonthly.com%2Fstory%2Flifestyle%2Ffood%2F2021%2F08%2F18%2Fwhat-expect-el-segundo-cmrs-forthcoming-mexican-restaurant%2F8184097002%2F" data-t-l=:i|v|c|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=:i|v|c|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><div class="gnt_tb gnt_tbb"><div id=gnt_tbw_1></div></div></article><div class=gnt_rr><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__pf"><div id=ad-slot-7103-oh-columbus-monthly-C6771-poster-lifestyle-food-5 class="gnt_x_sl gnt_x_p"></div></aside><div class="gnt_tb gnt_tbr" data-t-l=":taboola (article rail)|e|taboola click"><div id=gnt_tbw_2></div></div><div class="gnt_m gnt_m_fs"><a href="https://cm.columbusmonthly.com/site-feedback/?platform=Tangent-Desktop&url=https%3A%2F%2Fwww.columbusmonthly.com%2Fstory%2Flifestyle%2Ffood%2F2021%2F08%2F18%2Fwhat-expect-el-segundo-cmrs-forthcoming-mexican-restaurant%2F8184097002%2F&marketName=columbusmonthly&cta=Right-Rail" class=gnt_m_fs_a data-t-l=":survey|v|c|We're always working..." aria-label="We're always working to improve your experience. Let us know what you think."></a></div><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__st"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-oh-columbus-monthly-C6771-poster_scroll-lifestyle-food-6 class="gnt_x_sl gnt_x_sl__st gnt_x_p"></div></aside></div><div class=gnt_xbr><a class=gnt_ar_xb data-g-r=base_xbutton href=/ data-t-l=:b|v|c|x aria-label=Close></a></div></main></div><footer class=gnt_ft data-g-r="lazy lazy_p" data-gl-type=method data-gl-method=shbd><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__lb"><div id=ad-slot-7103-oh-columbus-monthly-C6771-leaderboard_btf-lifestyle-food-7 class=gnt_x_lb></div></aside><svg class="gnt_ft_lg gnt__hbd" data-g-r=lazy_c alt="Columbus Monthly - Part of the USA Today Network"><use xlink:href=#gnt_svg_lg alt/></svg><div class="gnt_ft_lw gnt__hbd" data-g-r=lazy_c><div class=gnt_ft_ls aria-label=About><a href=http://www.gannett.com/careers/ class=gnt_ft_a data-t-l=:f|v|c|about:careers>Careers</a> <a href=https://cm.columbusmonthly.com/accessibility/ class=gnt_ft_a data-t-l=:f|v|c|about:accessibility>Accessibility</a> <a href=https://www.columbusmonthly.com/sitemap/ class=gnt_ft_a data-t-l=:f|v|c|about:site-map>Site Map</a> <a href=https://www.publicnoticesohio.com/ class=gnt_ft_a data-t-l=:f|v|c|about:legals>Legals</a> <a href=https://cm.columbusmonthly.com/ethical-conduct/ class=gnt_ft_a data-t-l=:f|v|c|about:our-ethical-principles>Our Ethical Principles</a> <a href=https://cm.columbusmonthly.com/terms/ class=gnt_ft_a data-t-l=:f|v|c|about:terms-of-service>Terms of Service</a> <a href=https://cm.columbusmonthly.com/privacy/ class=gnt_ft_a data-t-l=:f|v|c|about:privacy-policy>Privacy Policy</a> <a href=https://cm.columbusmonthly.com/privacy-policy/ class=gnt_ft_a data-t-l=:f|v|c|about:california-privacy-right>Your California Privacy Rights / Privacy Policy</a><button class="gnt_ft_a gnt_ft_a__bl" data-g-r=base_ottid data-t-l=:f|v|c|about:cookie-policy>Do Not Sell My Info / Cookie Policy</button></div><div class=gnt_ft_ls aria-label=Support><a href=https://help.columbusmonthly.com/contact-us class=gnt_ft_a data-t-l=:f|v|c|support:contact-us>Contact Us</a> <a href=https://supportlocal.usatoday.com/ class=gnt_ft_a data-t-l=:f|v|c|support:support-local-business>Support Local Business</a> <a href=https://www.advertisecolumbus.com/magazines class=gnt_ft_a data-t-l=:f|v|c|support:advertise-your-business>Advertise Your Business</a> <a href=https://cm.columbusmonthly.com/advertising-terms-conditions class=gnt_ft_a data-t-l=:f|v|c|support:advertising-terms-and-conditions>Advertising Terms and Conditions</a> <a href=https://help.columbusmonthly.com/ class=gnt_ft_a data-t-l=:f|v|c|support:help-center>Help Center</a> <a href="https://subscribe.pcspublink.com/WeBSIS4/Default.aspx?pub=CMON" class=gnt_ft_a data-t-l=:f|v|c|support:my-account>My Account</a> <a href=https://imagn.com/licensing-reprints/ class=gnt_ft_a data-t-l=:f|v|c|support:licensing-and-reprints>Licensing & Reprints</a> <a href=https://cm.columbusmonthly.com/site-feedback/ class=gnt_ft_a data-t-l=:f|v|c|support:feedback>Give Feedback</a></div><div class=gnt_ft_ls aria-label="Stay Connected"><a href=https://subscribe.columbusmonthly.com/ class=gnt_ft_a data-t-l=:f|v|c|stay-connected:subscribe-today>Subscribe Today</a> <a href=https://profile.columbusmonthly.com/newsletters/manage class=gnt_ft_a data-t-l=:f|v|c|stay-connected:newsletters>Newsletters</a> <a href=https://www.facebook.com/ColumbusMonthly class=gnt_ft_a data-t-l=:f|v|c|stay-connected:facebook>Facebook</a> <a href=https://twitter.com/columbusmonthly class=gnt_ft_a data-t-l=:f|v|c|stay-connected:twitter>Twitter</a> <a href=https://www.columbusmonthly.com/story/lifestyle/celebrations/wedding/planning/2021/06/15/sign-up-columbus-weddings-newsletter/7703587002/ class=gnt_ft_a data-t-l=:f|v|c|stay-connected:columbus-wedding-subscription>Columbus Weddings Subscription</a></div><div class=gnt_ft_ls aria-label="Our Partners"><a href=https://www.reviewed.com/ class=gnt_ft_a data-t-l=:f|v|c|our-partners:reviewed>Reviewed.com</a> <a href=https://www.10best.com/ class=gnt_ft_a data-t-l=:f|v|c|our-partners:10best>10Best</a> <a href=http://www.reachlocal.com/us/en class=gnt_ft_a data-t-l=:f|v|c|our-partners:reach-local>Reach Local</a> <a href=https://www.usatodaysportsplus.com/ class=gnt_ft_a data-t-l=:f|v|c|our-partners:usa-today-sports-plus>USA TODAY Sports+</a></div></div><div class=gnt_ft_cr elementtiming=footer-cr>© 2021 www.columbusmonthly.com. All rights reserved.</div></footer><script>if(gnt.luxEnabled&&(LUX={ae:[],al:[]},setTimeout(function(){gnt.addScript('/tangstatic/js/perf-q1a2z3ffa38c70.min.js',!0)},3E3),addEventListener("error",a=>{LUX.ae.push(a)}),"function"===typeof PerformanceObserver))try{LUX.al.po=new PerformanceObserver(a=>{LUX.al.push(...a.getEntries())}),LUX.al.po.observe({type:"longtask",buffered:!0})}catch(a){};</script><script>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</script><script async src=/tangstatic/js/main-q1a2z3f82099ad.min.js onerror="document.querySelectorAll('.gnt__hbd').forEach(e=>e.classList.remove('gnt__hbd'))"></script><script type="gnt/tmpl" data-tmpl-key=navgdp><div class="gnt_n_dd_oy gnt_n_dd__sz" data-g-r=nav_oy></div><div class="gnt_n_dd gnt_n_dd__sz" data-g-r="nav_dd nav_te nav_ff" tabindex=0></div>|styles|[data-g-s=nav_ao] .gnt_n_dd_bt_svg{transform:rotate(180deg);background:currentColor;fill:#303030}.gnt_n_dd_oy{display:none;left:0;right:0;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px))}.gnt_n_dd{overscroll-behavior-y:contain;overflow:auto;overflow-x:hidden;box-sizing:border-box;display:none;width:385px;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px));margin:0 0 0 -20px;padding:7px 20px 0 32px;border-top:5px solid #0098fe;background:#303030;color:#fff}[data-g-s=nav_ao] .gnt_n_dd__sz{display:block;position:absolute}</script><script type="gnt/tmpl" data-tmpl-key=navse><form class=gnt_n_se_fm data-g-r=nav_dd action=/search/ role=search><input class=gnt_n_se_fm_qr data-g-r=nav_pf name=q placeholder="What can we help you find?" mozactionhint=search enterkeyhint=search aria-label="Search query"/><button class=gnt_n_se_fm_sm data-t-l=${se}:r|r|u| aria-label=Submit><svg class=gnt_n_se_fm_sm_svg viewBox="0 0 18 18"><path d="M12.28 9.76H2V7.74h10.28l-2.23-2.31L11.43 4 16 8.75l-4.57 4.75-1.38-1.43 2.23-2.31z"/></svg></button></form>|styles|.gnt_n_se_fm{display:none;align-items:center;justify-content:center;position:absolute;left:0;right:0;height:180px;padding:0 0 15px;border-top:5px solid #0098fe;background:#303030}[data-g-s~=nav_ao] .gnt_n_se_fm{display:flex}.gnt_n_se_fm_qr{width:492px;height:46px;padding:0 50px 0 0;border-style:solid;border-width:0 0 2px;border-color:#fff;border-radius:0;outline:0;background:0 0;color:#fff;font:700 28px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif}.gnt_n_se_fm_qr::placeholder{opacity:1;color:#fff}.gnt_n_se_fm_qr:-webkit-autofill{box-shadow:inset 0 46px #303030;-webkit-text-fill-color:#fff}.gnt_n_se_fm_sm{width:60px;height:50px;border:0;margin:0 -15px 0 -45px;padding:0;outline-offset:-8px;fill:#fff;background:0 0;cursor:pointer}.gnt_n_se_fm_sm:hover{fill:#e0e0e0}.gnt_n_se_fm_sm_svg{width:42px;height:42px;margin-top:3px;stroke:#303030;stroke-width:.5px}</script><link rel=preload as=fetch type=application/json crossorigin=use-credentials href=/global-q1a2z37NJ2wHYeB7gfTR5sH27Q4XlxAcE.min.json /><link rel=dns-prefetch href=//images.taboola.com /><link rel=preconnect href=https://images.taboola.com /><script type=application/ld+json>[{"@context":"http://schema.org","@type":"NewsArticle","headline":"What to Expect at El Segundo, Cameron Mitchell’s Forthcoming Mexican Restaurant","description":"Cameron Mitchell Restaurants’ first Mexican concept is set to open Aug. 31 in the former Harvey & Ed’s space in the Short North.","url":"https://www.columbusmonthly.com/story/lifestyle/food/2021/08/18/what-expect-el-segundo-cmrs-forthcoming-mexican-restaurant/8184097002/","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.columbusmonthly.com/story/lifestyle/food/2021/08/18/what-expect-el-segundo-cmrs-forthcoming-mexican-restaurant/8184097002/"},"thumbnailUrl":"https://www.gannett-cdn.com/presto/2021/08/18/NCOM/17eff154-f329-487c-9fcc-251b94b8dd38-CCP_6849_1.jpg?crop=3840,3840,x959,y0&width=150&height=150&format=pjpg&auto=webp","image":{"@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2021/08/18/NCOM/17eff154-f329-487c-9fcc-251b94b8dd38-CCP_6849_1.jpg?crop=5759,3240,x0,y192&width=1600&height=800&format=pjpg&auto=webp","height":800,"width":1600},"datePublished":"2021-08-18T19:14:03Z","dateCreated":"2021-08-18T19:14:03Z","dateModified":"2021-08-18T19:59:39Z","articleSection":"lifestyle","publisher":{"@type":"Organization","name":"Columbus Monthly","logo":"https://www.columbusmonthly.com/sitelogos/m-oc.svg"},"author":["Erin Edwards"],"keywords":["access:metered","ssts:lifestyle:food","type:story","tag:New Restaurants","tag:Overall Positive","tag:Columbus, OH","tag:Mexican restaurants","tag:Margaritas"],"isAccessibleForFree":true,"isPartOf":{"@type":["CreativeWork","Product"],"name":"Columbus Monthly - Unlimited Digital Access","productID":"columbusmonthly.com:standard"},"metadata":"{\"id\":\"8184097002\",\"siteCode\":\"NCOM\",\"contentSourceCode\":\"NCOM\",\"ssts\":\"lifestyle:food\",\"type\":\"story\"}"},{"@context":"http://schema.org","@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2021/08/18/NCOM/17eff154-f329-487c-9fcc-251b94b8dd38-CCP_6849_1.jpg","caption":"A selection of tacos from El Segundo Mexican Kitchen","copyrightHolder":"Courtesy Cameron Mitchell Restaurants"},{"@context":"http://schema.org","@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2021/08/18/NCOM/536b7ea5-cb2d-4590-bb73-98fcb3aa7f03-IMG_6930_1.jpg","caption":"The bar at El Segundo Mexican Kitchen, which opens August 31","copyrightHolder":"Erin Edwards"},{"@context":"http://schema.org","@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2021/08/18/NCOM/21978e04-3118-4f47-9837-44067b9d2a90-CCP_6951.jpg","caption":"Tres leches at El Segundo Mexican Kitchen","copyrightHolder":"Courtesy Cameron Mitchell Restaurants"}]</script></body></html>